05/01/2023 11:21 (*.17.160.158)
3600

To answer on FORM/POST for login

 

Dim result As String = ""
Dim WEB = New Net.WebClient()

 

Dim LoginData As System.Collections.Specialized.NameValueCollection = New System.Collections.Specialized.NameValueCollection()

LoginData.Add("user[email]", ID)       // depend on the form field title
LoginData.Add("user[password]", PW)    // depend on the form field title

 

Try
   result = Text.Encoding.UTF8.GetString(WEB.UploadValues(URL, "POST", LoginData))
Catch ex As Exception
   result = ""
End Try

05/01/2023 11:17 (*.17.160.158)
1597

It is pretty easy to apply

 

Dim WEB = New Net.WebClient()

WEB.Headers("Content-Type") = "application/json"
WEB.Headers("Authorization") = "Bearer " & varToken

Try
    result = WEB.UploadString(varURL&, "POST", "")
 Catch ex As Exception
    Return ("")
End Try

Return result

 

Just add a token into header, and can access URL

 

 

There are so many web base devices, and some webserver device do not have a valid certification,

While access HTTPS using Webclient, will get a trouble with Certification if there is no valid one.

When I access Envoy Local Servier using HTTPS, I have expericed it.

 

First, create a Validation Server Function as below

 

Public Function ValidateServerCertificate(ByVal sender As Object, ByVal certificate As Object, ByVal chain As Object, ByVal sslPolicyErrors As Net.Security.SslPolicyErrors) As Boolean


        Return True


End Function

 

And, Connect the validate server as

 

Net.ServicePointManager.ServerCertificateValidationCallback = New System.Net.Security.RemoteCertificateValidationCallback(AddressOf ValidateServerCertificate)

 

When call HTTPS using Webclient, Webclient server will call the user defined server code, and can over-ride an error 

 

You can put the code into MAIN() -0r-  Sub New() once

04/30/2023 10:51 (*.17.160.158)
5254

From Evnvoy FW7, Just can login into Enovy using Bearer Token,

 

I have made a simple code using VB.NET to

    (1) Retrieve a Token from Enphase Token Website

    (2) Using the Token, access Enovy's Data

 

Note. Need to add a certification validating code for Envoy, because envoy's certification is not valid.

Note. Ihave added json.vb for JSON file decord and using in the code        

04/03/2023 09:39 (*.17.160.158)
773

Recently, I have bought Tesla Model 3, and I have decided to expand solar power for this vehicle.

and, Installed 4 used panel which have bought from eBay

 

a.jpg

 

270W panels, 10+ years old, and the actual power is around 240~250W.

Include the wood frame, I have spent $200. Due to the power expansion, I have upgraded my charger also,

 

b.jpg

 

This is a 96V charger, but support 48V battery. and allowed up to 180V input (in H/W, 250V is maximum).

 

I have spent around $400 total, and $280 after tax credit.

 

the estimated energy per year is 900~1000kWh per year, it is $170~$185 value. and I can return my investment atter 1.5years.

When use a home back-up power using Generator or Inverter, the peak power usage of the centeral AC is the biggest trouble maker. such as I have been using XW Pro for the whole house back-up, this inverter has 6.8kW continous power and 13.2kW peak power base on the view of Central AC. This inverter can run my 2.5t Centernal AC's Compressor but there are so high tranformer noises.

 

I have decided to install a soft-starter to reduce the peak power demand when start-up,

My AC's LRA is 67A (16kW), it is too high to handle by my inverter, but, practical usage is just around 40A (10kW). it is why my inverter can support barely. BUT, if there is the other temporary load, my inverter will got damaged if running without a soft-starter.

 

my AC is not smart enough, and it can be stalled, it means, can lost a key parts.

 

Micro-Air EasyStart 368 is an only solution in the market, this is the connection method

 

 

method.jpeg

 

and, final

 

install.jpeg

 

At the first run with soft-starter

 

before.png

 

Peak demand is 37A (~9kW), 

 

after.png

 

From the second run, the peak demand has reduced to 18A (~ 4.5kW), not, there is a marginal power for the other loads.  and, Motor/Compressor starting power has soften clearly.

07/19/2022 11:25 (*.63.236.74)
901

Untitled.jpg

 

'No Grid Profile' means the inverter has bricked,

and then, recovered by watch-dog reset.

and, 5min start-up delay.

 

If say a result first, nothing improved yet.

 

More evidence(users) are complaining Ehphase IQ7+ Inverters are showing Random Produciton Drop with 'No Grid Profile' error with Firmware v4.27 or v4.28. I have thought firmware v4.28 can resolve the issue, but, not.

 

Now, I decide to change wiring for all inverters to check the difference.

This is the current layout, there is no issue at Rear Roof, Only issue at Front Side Upper/Lower Roof.

So, I just try to simplify the front root layout.


This is the current layout, 

 

layout_before.jpg

 

i have updated the layout as below

 

(1) rear roof  - I have reduced the Q-cable length by 4'

 

(2) front roof - change the wiring, and reduce the power on the wire by half. the length has reduced by 4'. and, it is a new wire from roof to load-center usung 10 AWG THHN-2, have installed an independent breaker. 

 

(3) porch - direct to JB, No more path thru on front roof panels, so, the power path have reduced by 12'

 

 

layout_after.jpg

 

Base on my calculation, this change has lmproved for the voltage rising and interference of panels (inverters). 

 

layout_single_line.jpg

The first day of test, I cannot find any noticeable difference. actually, the inverters are showing error continously. (OTL), but, I wish to compare the difference before/after the layout changes (if there is any improvements)
 

 

 

 

 

02/28/2022 17:58 (*.63.236.74)
1784

 

1. Will getting worse

2. Not related with GRID - no need to check grid or profile

3. Just power on reset - at first power on reset, it is showing 'Grid Instability Error' because no grid profile

 

https://support.enphase.com/s/question/0D52G00004ZVmwjSAD/anyone-else-having-issue-with-some-of-their-iq7-microinverters-randomly-dropping-out-around-the-same-time-every-day

 

https://support.enphase.com/s/question/0D53m00007P62ncCAB/grid-instability-issue-anyone-have-similar-issue-

 

 

I have requested a detail information abut LCF-064-1P,

     Enphase - datasheet only

     Manufacturer - can not provide it because customized item

 

No more solution with LCF, I have decided to return the filter on Enphase,

I am not sure the part is no good, or filtering is not enough. 

 

So, I start to find the solution on my way,

 

I have reinstalled RP230-30-10-S and GTX-2300

 

    BUT, it has too high line loss, so, I have disassembled & checked GTX-2300.

    the coil configuration is the two-in-hand winding, it is good for common mode filtering, But, it has lower magnetic 

leakage, so,not good for differential mode filtering. it is not much useful for me.

    so, I have removed it. and, reduce 0.5mA leakage current & 10mOhm Resistance Loss

 

     ferrite_winding.png

 

        RP230-30-10-S have 60dB 50/50 insertion loss, but, can not block

the signal from next door also, I guess, my noise level at my home is too quiet and no one use PLC devices.

Yes, high SNR, so, just Envoy signal can be detected too easily.

 

      so, I have decided to add an extra differential mode filter using ferrite

 

rp230-double_d.png

 

Ferrite core is B64290L0082X065

 

and, look the wire direction, it is the coupled differential mode, and 2 turns.

over one day, it can isolated successfuly, the expected core loss is 200-300Wh per year. 

it is much less than 1~2kWh in GTX-2300-Y02. 

 

This configuration will be saturated under 10A. so, I have tried on single turn. 

at least, I need 20A because higher current will act as a noise, and will reduce the sensitivity of enovy.

and, I just need this inductor is working at the lower current (quite) zone.

 

rp230-single_d.png

 

This is final configuration.

It is working well, now, my system has been isolated completely.

and, no more cross-domain-traffic issue.

 

The cost of Ferrite & RP230 filter is just $80, and under $100 include tax & shipping.

It will working when system current is under 24A (around 20, IQ7+),

If want to apply on the bigger system, need bigger filter

 

 

 

 

AB71E8E4-2B47-4EEC-9AC0-680B57489861 

I have installed shortest wiring, and no overlap to avoid a crosstalk, and just put one Ferrite core to filter a common mode for wire organizing and 10cm overcome earth wires. It may affect on the high frequency, but, it is not our concern because LCF is for 110kHz L-to-L PLC & Noise filtering now.
 

Let me check what will happening, 

 

Updated on NOV 29 2021

 

Long story is short, It is not working

 

LCF.png

This is an error what I do not want to get..

I have requested some advice and, Enphase said

 

Avoid a magnetic PLC coupling by

  - Own enclouser :: it is related with a distance, but, -.-a

  - 12" distance between conductor  :: point to point is not important, parallel run is the key

 

Anyway, I have installed as

 

LCF_ext.png

 

If I add an enclouser for the filter, I have to get a permit & inspection from local office. it become so complicated issue. and, I feel, so strange, the engineer do not understand what is the real problem.

 

anyway, I am not sure what is the cause why it can not block the signal from my next door, 

i understand as it is a customized part for IQ. Maybe it is just a issue of my part. 

 

while low current, Enovy is detecting the other enovy at outside.

IT is happening because my house has very quite in electric noise.

if not cut-out completely, the filter is not enough because still high SNR. 

 

 

11/24/2021 16:21 (*.17.160.158)
2102

Very good video what is difference between Mico and String Inverters

 

 

Micro vs String Inverter

 

 

You have to watch it before install a solar system.

 

Enphase MI system is much expensive than String inverter,

even more than Optimizer system.

 

But, String inverter system need 6+ panels in series, it means there is a minimum number of panels under similar sun-light condition. but, MI system do not have the minimum requirments, technically 1 panel.

 

so, if have small zone & multi zones (more than 2), MI should be better

except this condition, There is no advantage via the extra cost

We knew Enphase Envoy and Inverters are communicating using Power Line Carrier,

 

The Envoy IQ is using Line-to-Line Singal instead Envoy-S's Line-to-N/G Signal.

 

It is a huge difference, because Envoy IQ is generating Differential mode signal

and, OLD Envoy is generating Common mode signal

 

To filter the signal from my neighborhood (he has installed Solar System last summer, unfotunately, he & I under the same utility tranformer). To solve the cross domain traffic issue, I need to filter the differential mode signal.

 

I have installed RP230-30-10-S between IQ combiner busbar And Wire_to_load_center.

It is suggested for Envoy-S (Line-to-N/G) system. but, Double stage filter has a good filtering on DM signal. Especially, this model shows 60dB insertion loss on DM. so, I have expected, it will filter the signal.

 

Insertion Loss (dB) = 20 * log10 ( Unfiltered / Filtered)

60dB means, 20 * 3 = 1000/1, the signal should be filtered by 1/1000 at 150kHz

Even consider some decay at 100kHz, the filtering performance should be 1/100 or better.

Leakage current of this filter is 1.8mA, it is pretty high loss

 

https://www4.enphase.com/sites/default/files/Power_Line_Filter_Single-Phase_TechBrief.pdf?utm_source=community&utm_medium=answer_links&utm_campaign=internal_reference

 

DC0A11E8-EB68-4EFD-9056-FA03F0716AE8 

 

but, envoy is showing ‘Communications from other Envoy(s) have been detected’ early morning. And it is disappearing till evening, and showing again.

 

I have installed GTX-2300-Y02 between Wire_from_envoy and Breaker_Load_Center

 

Insersion loss is around 20dB in common mode. there is no differential value.

I am expecting around 10dB minimum, but, the leakage current is 0.5mA,

Too expensive to use it,

 

https://www.mouser.com/ProductDetail/KEMET/GTX-2300-Y02?qs=yqaQSyyJnNgbwvs18djAZg%3D%3D

 

4F2F6189-9337-4344-910D-39322A18EA18 

 

Load center and combiner has located as below

 

854901D7-5E75-4C70-95EB-4E6484BAACDF 

 

MI - Combiner - RP230 - GTX2300 - Critical Load Center - XW 6848 - Main Load Center - Grid

 

Unfutunately, it can not solve the issue,

the message come again and again ~ like a die hard ....

 

Wait a minitue, just thinking again,

 

Common mode signal.JPG

 

New Envoy is Line-to-Line communication, so, I have to remove/block a differential mode signal,

it means, the common mode filter is not working.

 

  • Envoy-S    same as Common Mode Signal
  • Envoy-IQ   same as Differential Signal

 

If install Ferrite Core on L1/L2, yes, it should not working -.-, that is just for old Enovy ONLY. !!!!

 

GTX-2300, it is a typical single stage common filter, it is good on common noise, and, have some filter for differential mode noise, i feel, that is not strong enough.

 

 

 

and, RP230-30-10, It is double stage filter, it have 60dB insertion loss on DM at 150kHz.

 

 

Unfotunately, those filters can not block the signal and, my envoy still detect the other Envoy(s). 

 

 

BUT, I feel so strange,

 

(1) it is detected when early morning  - when MIs start to work

(2) it is detected when evening - when MIs stop to work

(3) sometime at evening

 

so, I have tried to check the noise level and filtering level using SA

 

DAD3F7CA-2C54-4621-B374-745F5F4EF95C

 

it makes me so disappointed, because I can not detect any signal from outside for couple of hours.

I have checked my device again, turn-on Enovy and check the signal

 

EFEA448A-695F-48BB-81AA-97C57963B82D

 

My equiment can detect a communication signal which has been generating from my Envoy.

I can find a signal, and confirm the filtering even I can not find the exact level of filtering.

 

[SO, THERE IS A BASIC QUESTION]

 

How my Envoy detect the other Envoy(s) signal ?

How my Envoy detect the other Envoy(s) signal after 2 filters ? there is 60dB insertion loss. Is it possible to be detected ?

 

ANYWAY, most power line filter is designed to minimize the power loss using small capacitor.

It means, not strong enogh on DM filtering, BUT, can not explain the the message while low power mode. Because filter will lost the performance while higher current mode,

 

I have ordered Q-LCF-064-1P-1 to make sure,

 

Because it said, IQ compatible,

 

75W maximum loss (via the maximum current), should be under 1/16 at my appliaction.

anyway, around ~19Wh is so high power consumption 

 

75W x 1/16 & 4.15h = 19Wh per day (or 7.1kWh per year)


Maybe need to try for the DM mode noise

11/08/2021 16:17 (*.17.160.158)
1084

This is showing how cable has connected and where is the panel/inverter has installed on my roof.

 

layout_a.png

 

This is an simple electric node diagram,

Pretty complex tree than my expectation,

When I have chance, I should clean-up and optimize the wire routing.

becuase I found so many duplicate path, and far routings.

 

(1) remove cap from top route (between 12-13)

(2) install cap on end of 07

(3) move jumper wire between bottom and middle route, on top - middle

(4) move JB-middle to JB-bottom

 

and then, Break #1 route will have 9 inverters (longest 6 node)

and, Breaker #2 route will have 6 inverters,

 

for this job, jumper cable should enought to jump from mid to top.

little doubt ...

 

Maybe need

    50' Q-cable

    2  female connector to make an extension cable

    1  terminator

    1  cap

    1  connector disassembly clip/jig

 

Actually, the best method is

    (1) make an extra route from bottom to JB

    (2) update JB

 

But, need enough wire clips ...... so many....

 

layout_b.png

 

I am sharing a question on Enphase Community

 

https://community.enphase.com/s/question/0D53m00007P62ncCAB/grid-instability-issue-anyone-have-similar-issue-

 

It is a known issue, but, No one answer it. 

It is a FW of Inverter or Inverter's Problem, 

Due to this issue, can lost 2-4% Pure Production in System, 

Because eqch drop will affect 1.5% lost. 

 

// Contents //

 

I have bought Paid Manager service to check in detail, 

I just find any advice or idea who have experienced it before

 

temperature_spike_7dThis is 7d graph, you can see the green spike, that is the point of issue, 

I have checked in detail 

 

issue_beforeBefore the trouble, everything looks no issue, 

BUT, if check DC current, there is an different story

 

issue_right_before_recover 

DC current is not 0A, it is 0.59A with 40.34V DC voltage. 

micro inverter is not just shut-down, it is eating DC current, and temperature is going up

it is the temperature spike which has shown 7d graph. 

 

First issue has started on Aug 17, and it become more and frequently, 

Second issued inverter has started on Sep 2, and it become more and frequently. 

3 inverters are twice a day, and 2 inverters are once per 2-3 days. 

not sure, it will get worse or not. 

 

Any idea or advice about it ? 

 

ADD/EDIT: 

This issue has started on AUG/SEP 2021

and, getting worse - more frequently, 

Finally, it start to shutdown 3 times per inverter 

 

a 

ADD/EDIT : Bad news, It is affect on actual production

 

B84C6C6D-31D1-47C2-BA5B-86211EBCC0E8If see the green line, can see a power down at noon (it is average of 3 zone, 4-6 inverters are showing issue at only one zone even installed all at same time)

three inverters are showing error at similar time around noon. 

 

0E5DB1A8-59E5-4F04-959E-74212D589833it is power level using Production Meter Reading at Envoy every minute. 

yes, production rate is slowing down little bit at noon, 

It means, It is real Shut-down & No Production. 

 

ADD/EDIT : Is it really grid instability ? 

980E17FE-0D7D-43CC-AC97-339F2CE0EAF7I am running my system using AC Coupling Mode, GRID voltage is 237V (20V lower than actual 

grid voltage), and much stable. i have add RP230-30-10 filter, and 5 ferrite ring on L1/2 to filter 

noise. The issue has not been improved at all, not worst or better, same.

 

15161EED-9DE9-429A-8A41-C82E7AC8BF74 

i have 3 groups, the first string is, Group1-Group2-Junction-Envoy // 2nd string is Group3 - Junction - Envoy. No issue on 2nd string at all. Most of Group 1 show an issue, 1 out of 5 at group 2 shows an issue, 2-3 times per week.

 

10/25/2021 17:31 (*.17.160.158)
1166

I have decide to install a wood racking for two solar panel at my back yard,

Becuase comercial racking is too expensive.

I should install between two shed

 

before.png

 

I made a simple design using power point,

Yes, it is not professional... but, just enough information

 

design_concept.png

 

The best tilt is 34deg. but, I decide as 31deg to simplify 

 

Time to buy wood & screw at homedepot,

I have bought 4"x4" 6' 6EA for post, and 5/4"x6" 5EA for beam/support.

my SUV can not hold 10', so, I waste some 4"x4" woods

 

woods.png

screw.png

 

Cutting & assemble,

Follwing the design

 

wood_work.png

 

yes, finally, I have finished the first stage as

 

after.png

 

All assembly is pretty heavy, over 100lb.

If assemble two solar panel, it will be more than 200lb.

 

I have use Mailbox Ground Anchor to hold each post.

 

mailbox_ankor.png

 

In fact, I doubt, I really need it or not. Actually, it is expensive $32/post ($192 for 6 posts)

(all wood & screw is just $110)

I do not recommend to use it. If not much water contact with wood frame.

just add some support beam at bottom side, it will be enough.

in my case, very high wind because next door

and, water collecting area while raining.

so, I decide to make some kind of offset from the ground. so, I have used those achors.

 

Now, I am waiting panels..

10/25/2021 17:07 (*.17.160.158)
1167

Solar Report.png

 

At my location, the maximum possible production is around 6.711MWh with my system.

* 15 LG350N1C with IQ7+

 

But, Panels are installed on the three different location with various direction/tilt.

When consider the installation, Maximum value is 6.314MWh

But, I just get 6.166MWh due to the shading of dome/tree.

 

My estimated production is 6.129MWh (NREL Model 6.185MWh),

봄이조아
04/01/2021 14:40 (*.17.160.158)
49848

One of critical issue with an AC coupling system is happening when battery has fully discharged.

There is no way to recover back.

 

So, I decide to install an addtional DC coupling

as below

 

Picture1.png

 

 

Two panasonic HIT340 module on the shed at my back yard.

 

2 pannels are connected in series, it can generate 680W. (practically, it can generate 760~780W).

 

back_solar.png

 

 

I have installed cheap MPPT charger,

Actually, this model can support 190V input, and working up to 160V.

When I make 2s 96cell module, Voc is around 130-140V. and Vmppt is around 120V.

It is too hard to use a generic 150V charger.

but, this MPPT controller is perfect in my case.

 

mppt.png

 

 

This is final connection,

 

I have installed 200W 48V to 12V DC2DC for Mini-computer (monitoring), NAS (Data storage & Web Server)

and Wireless Router (to keep on an in-house network).

 

whole system.png

 

I have installed 30kWh battery power

 

The useable capacity is around 24~25kWh. and, It is enough to supply 24 hours full power usage.

or 2-3 days limited power usage at my house.

 

 

 

battery_dc_load.png

 

 

http://www.forby.com/solar/?detail=1&offset=0

 

 

The most people charge thier computer or smart phone frequently, and try to keep in full charge status.

They have to understand that is the worst habit to use a lithium chemistry.

 

When keep the high charge status over long time, battery degradation is happening.

Will lost capacity permanently, this damage can be increased with the temperature of battery (device).

 

This is why no one recommend do not keep charging all the time, to reduce the average status of charge.

 

 

 

IMG_2308.jpeg